Back to overview
Degraded
Dashboard & API unavailable
May 29, 2024 at 11:15am UTC
Affected services
Dashboard
API
Resolved
May 29, 2024 at 12:18pm UTC
All systems are operating smoothly
Affected services
Created
May 29, 2024 at 11:15am UTC
Some users report our dashboard and API being unavailable. We are investigating this issue.
Affected services