Back to overview
Downtime
Support portal unavailable
Jan 29 at 08:11am CST
Affected services
Support portal
Resolved
Jan 30 at 09:01am CST
Our vendor has fixed the issue with our ticketing system
Affected services
Created
Jan 29 at 08:11am CST
Our support portal is currently unavailable. We are working with the vendor to fix it. During this time, our answer times may be longer but your messages reach us.
Affected services